G is for Gallery

I broke the photo album / gallery on this site ages ago, and since fixing it is going to be a long and arduous process, I haven’t done it yet.  But I’m going to set myself a(nother) challenge for this month, to get that finally sorted out, so I can have access to my photos on this site again.  Which, you know, would be (a) nice, and (b) useful.

Basically what happened, as far as I can tell (and as if anyone but me really cares), is that when I installed a WordPress gallery plugin (NextGen Gallery) to have a look at, it violently disagreed with my already installed gallery software (Coppermine), which had a bridge WP plugin so I could easily access my already existing photo galleries from there when I was writing blog posts etc.  Coppermine had been installed for years, long before I’d been using WP as my blogging platform.  Anyway, I don’t know what exactly caused it all to have a hissy fit, but I do know that none of my photos now show up, despite them physically existing on the server.  Marvellous!  I tried uninstalling NextGen Gallery, but since that didn’t help, I’m now going to move everything across to NextGen instead, and drop poor old Coppermine.  It’ll probably be easier in the long run, and I won’t have to be maintaining two databases etc any more.  But moving it all across is going to take a while, and be a pain.

If I do it a little at a time, though, it shouldn’t be too bad.  I think I’ll try to spend maybe an hour a day on it.  Surely that way it should get done pretty quickly?!  And also I’ll know for sure how long it does take me, rather than it just feeling unending.  I think giving myself permission to stop working on it after a specific period will help, too.  Let’s see how it works out.

This entry was posted in NaBloPoMo, Photo album, Webby Admin and tagged , , , , , , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *